
Computer Caught in Reboot Loop After Using DriveSpace
- Document ID: 94000581
- Posted Date: 1996-08-19
- Last Updated: 1996-08-19
- Distribution: View Public Website
- Applicable Models
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- Information
- Computer Caught in Reboot Loop After Using DriveSpace
SYMPTOMS
When you are using DriveSpace to compress a drive, your computer may become stuck in a reboot (or restart) loop. If you press the F8 key when your computer restarts and then choose Command Prompt Only, your computer enters the reboot loop again. If you choose Step-By-Step Confirmation, you can start Windows 95. However, when you run DriveSpace, your computer enters the reboot loop again.
CAUSE
This problem can occur if any of the following conditions exists:
- A "DRVSpace=0" or "DBLSpace=0" setting is present in the Msdos.sys file.
- The Drvspace.bin or the Dblspace.bin file is damaged and was not loaded at startup.
- You load the EMM386 memory manager and you are using the lower E000 range. This behavior has occurred on Compaq Deskpro 386/20e computers and may occur on other computers.
RESOLUTION
To resolve this problem, follow these steps:
1. If the "DRVSpace=0" or "DBLSpace=0" setting exists in the Msdos.sys file, disable the setting by placing a semicolon (;) at the beginning of the line. For example:;DRVSpace=0
For information about how to edit the Msdos.sys file, please see the following article in the Microsoft Knowledge Base:
ARTICLE-ID: Q118579
TITLE : Contents of the Windows Msdos.sys File
If the "DRVSpace=0" or "DBLSpace=0" setting does not exist in the Msdos.sys file, or if this step does not resolve the problem, proceed to the next step.
2. Rename the existing Drvspace.bin and Dblspace.bin files and then extract new copies of the files from your original Windows 95 disks or CD-ROM. To do so, follow these steps:
a. Restart your computer. When you see the "Starting Windows 95" message, press the F8
key, and then choose Safe Mode Command Prompt Only from the Startup menu.
b. Delete the Restart.drv file from the hidden Failsafe.drv folder on the physical boot drive
(usually either drive C or the host for drive C if drive C is compressed). To do so, type the
following command at the command prompt deltree:\failsafe.drv\restart.drv where
is the physical boot drive.
c. Copy the Autoexec.bat and Config.sys files from the hidden Failsafe.drv folder on the
physical boot drive (usually either drive C or the host for drive C if drive C is compressed)
to the root folder of drive C, replacing the files that are already there. To do so, type the
following commands at the command prompt
copy:\failsafe.drv\autoexec.bat c:\ /y
copy:\failsafe.drv\config.sys c:\ /y
whereis the physical boot drive.
d. Remove the Read-Only, System, and Hidden attributes from the Drvspace.bin and
Dblspace.bin files in the root folder of the physical boot drive (usually either drive C or the
host for drive C if drive C is compressed). To do so, type the following command at
the command prompt: attrib -r -s -h *.bin
e. Rename the Drvspace.bin and Dblspace.bin files in the root folder of the physical boot
drive (usually either drive C or the host for drive C if drive C is compressed). To do so, type
the following command at the command prompt: ren *.bin *.bix
f. If you use Microsoft Plus!, extract the Drvspace.bin file from your original Microsoft Plus!
disks or CD-ROM to the root folder of the physical boot drive (usually either drive C or the
host for drive C if drive C is compressed).
If you do not use Microsoft Plus!, extract the Drvspace.bin file from your original Windows 95 disks or CD-ROM to the root folder of the physical boot drive (usually either drive C or the host for drive C if drive C is compressed).
If you use OEM Service Release 2, extract the Drvspace.bin file from your original OEM Service Release 2 disks or CD-ROM to the root folder of the physical boot drive (usually either drive C or the host for drive C if drive C is compressed).
For information about using the Extract tool, please see the following article in the Microsoft Knowledge Base:
ARTICLE-ID: Q129605
TITLE : How to Extract Original Compressed Windows Files
g. Copy the Drvspace.bin file in the root folder of the physical boot drive (usually either drive C or
the host for drive C if drive C is compressed) to a file named Dblspace.bin in the root folder of
the physical boot drive (usually either drive C or the host for drive C if drive C is compressed).
To do so, type the following lines at the
command prompt copy:\drvspace.bin c:\dblspace.bin
whereis the physical boot drive.
If drive C is compressed, copy the Drvspace.bin file to the root folder of the host drive. To do so, type the following command at the command prompt
copy:\drvspace.bin :\dblspace.bin
whereis the physical boot drive and is the host drive for drive C.
h. Restart your computer normally.
If this step does not resolve the problem, proceed to the next step.
3. To allow DriveSpace to finish successfully, do not load Emm386.exe. To do so, follow these steps:
a. Restart your computer. When you see the "Starting Windows 95" message, press the F8
key, and then choose Step-By-Step Confirmation from the Startup menu.
b. Press Y at each prompt except when you are prompted to start EMM386. Press N at this
prompt.
MORE INFORMATION
================
When you compress an existing drive, Windows 95 must load the real-mode compression drivers into memory. As Windows 95 restarts the computer in mini-Windows, Restart.drv tests for the existence of the real-mode compression drivers. If the real-mode compression drivers have not been loaded, the computer is restarted until the compression drivers have been
loaded. If the real-mode compression drivers cannot be loaded, the computer restarts indefinitely.
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