CTL3DV2.DLL



Document ID: 94000264

 

Posted Date: 1996-08-19

 

Last Updated: 1996-08-19

 

Distribution: View Public Website

 

Applicable Models
Satellite 100CS
Satellite 110CS
Satellite 110CT
Satellite 200CDS
Portege 610CT
Portege 650CT
Portege 660CDT
Tecra 500CDT
Tecra 500CS
Tecra 510CDT
Tecra 530CDT
Tecra 700CS
Tecra 700CT
Tecra 710CDT
Tecra 720CDT
Tecra 730CDT
Tecra 730XCDT
Tecra 740CDT
Satellite Pro 400CDT
Satellite Pro 400CS
Satellite Pro 415CS
Satellite Pro 425CDS
Satellite Pro 430CDS
Satellite Pro 430CDT

 

Information
SYMPTOMS

When you double-click the Microsoft Works icon to start the program, you receive the following error:

This application uses CTL3DV2.DLL, which has not been correctly installed.

If you choose the OK button to close the error message, Works starts and appears to run normally.

CAUSE

This error can be caused by one or more of the following:
  1. Multiple copies of, or an improperly located copy of, CTL3DV2.DLL
  2. A damaged or corrupted CTL3DV2.DLL file
  3. A damaged or corrupted COMMDLG.DLL file


RESOLUTION

I. Determine if There Are Multiple Copies of CTL3DV2.DLL
  1. Search the hard drive for multiple copies of CTL3DV2.DLL.
  2. If more than one copy of CTL3DV2.DLL is found and Windows is installed locally, remove all copies except the one located in the Windows SYSTEM subdirectory.
  3. If more than one copy of CTL3DV2.DLL is found and Windows is shared from a network server, remove all copies except the one located in the shared Windows directory on the server (that is, the directory where all of the Windows system files are located.)
  4. If only one copy of the file is found and it is located in the Windows SYSTEM subdirectory or the shared Windows directory on the server, follow the steps below.


II. Replace the CTL3DV2.DLL File with a New Copy from Your Works Disks
  1. If you are using Windows 3.x, exit Windows. At the MS-DOS command prompt, rename the existing version of CTL3DV2.DLL to CTL3DV2.OLD.
  2. Switch to the directory containing the file DECOMP.EXE: If Works was installed on an individual computer, switch to the MSWORKS\SETUP directory on the hard drive. If Works was installed on a network server, change to the shared Works directory on the server.
  3. Insert Disk 3 if you are using Works 3.0, or Disk 4 if you are using Works version 3.0a or 3.0b, and type the following at the MS-DOS command prompt: decomp :\ctl3dv2.dl_ ctl3dv2.dll where is the drive letter where the Works Setup disk is located, and is the complete path to the Windows SYSTEM subdirectory
  4. Start Windows and Works to determine if the problem has been resolved. If not, continue with the steps below.


III. Replace the COMMDLG.DLL File with a New Copy from Your Windows Disks
  1. Search the hard drive for multiple copies of COMMDLG.DLL.
  2. If you are using Windows 3.x, exit Windows. At the MS-DOS command prompt, rename each existing copy of COMMDLG.DLL to COMMDLG.OLD
  3. Change to the directory containing EXPAND.EXE (it's usually in the Windows directory).
  4. If you are using Windows 3.1, or Windows 3.11, insert your Windows Setup disk 4 into the floppy disk drive. If you are using Windows for Workgroups 3.11, insert Setup disk 1 (1.44 MB) and type the following at the MS-DOS command prompt: expand :\commdlg.dl_ commdlg.dll where is the drive letter where the Windows Setup disk is loca
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